В новых версиях wordpress будут ужесточены минимальные системные требования. WordPress перестанет поддерживать php4 и mysql 4.

С одно стороны это плохо, т.к. это не позволит использовать wordpress на «устаревших» хостингах. Именно массовость является одним из положительных факторов wordpress, что систему можно развернуть почти на любом хостинге.

Но с другой стороны, сколько можно? Разработчики php уже давно заявили, что php 4 развивается последний год, так почему разработчики wordpress должны привязываться к php4? Тем более, что большая часть хостингов уже давно поддерживает php 5 и найти хостинг с поддержкой php 4 с каждым днем сложнее, это вполне логичный ход, я лично ничего плохого в этом не вижу.

Напротив, я искренне надеюсь, что отказ от php 4 и отказ от «дальней» обратной совместимости позволит улучшить код, внести в код какие-то более современные вещи, сделать движок легче.

Уже в wordpress 3.2 планируется полный отказ от php4 и mysql 4. Все дружно надеемся, что разработчики все таки смогут «облегчить» wordpress или по крайней мере не сделать его еще тяжелее.

Так что совсем не за горами, прежде чем установить wordpress нужно будет удостоверится, что вы пользуетесь услугами современного хостинга, который обновляет свое ПО, а не живет в каменном веке 😀

Прочтите также: